Hello, this is my first post here and it's about a problem I've run into upon installation of the 12.04 version of the Xubuntu distribution, it's my first time with an open OS and so far I haven't run into any major problems, with the exception of this one:

The problem is that I can't connect to my wireless network, I can connect to my router via an ethernet cable just fine, and I can even detect wireless networks as usual, but I can't connect to mine, even if I leave my network open without any protection/encription. It's (probably) not a problem with my router, as I can still connect to it using another computer or even this one when running Windows

My wireless card is a "Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe", I tried dowloading the newest linux-compatible official driver on the Ralink official site, but after the download of the file, wich appears to be "2010_07_16_RT2860_Linux_STA_v2.4.0.0.tar.bz2" , I can't seem to be able to extract it, it gives me a message saying that it isn't a valid bzip2 file:
$ tar -xjf 2010_07_16_RT2860_Linux_STA_v2.4.0.0.tar.bz2
bzip2: (stdin) is not a bzip2 file.
tar: Child returned status 2
tar: Error is not recoverable: exiting now
I don't know if my problem would be solved upon installation of the new driver, but I'm not sure of what else I could do to try to fix it

I thank anyone who could spare his time to assist me

As a side note, english is not my native language, so please give me some feedback on my spelling and point out any mistakes I may end up doing