Sorted out the touchpad problem, turned out to be a really simple matter of tweaking the settings a little bit.
Adding xorg-edgers to software sources as suggested on the wiki enabled four-finger gestures. To enable two-finger scrolling and three-finger gestures :
I went to system settings > mouse/touchpad settings, and enabled two finger scrolling in the options.
Then, I ran
synclient ClickFinger3=0
synclient TapButton3=0
to enable three-finger gestures.
(and set these to run at session startup)
I think this might only be relevant to Unity users.