ccsm >> unity plugin >> switcher tab >> uncheck "shown minimized windows in switcher"
(optional) ccsm >> disable workarounds OR ccsm >> workarounds >> uncheck "keep previws of minimized windows"
Optional step fixes maximized windows, at least worked for me.
Ubuntu 12.10 x64, Nvidia GTX 275, proprietary drivers 310.14, compiz+unity