I hope you don't mind me tagging onto this post. I have a Z585 also & I have been researching in all my spare time about installing Linux on this new machine. A10 AMD Quad Core, 6GB Ram, DVD-RW, 750GB 5400rpm HD.

I have run Ubuntu on various machines since 2007.

I recently added LM 13 (Linux Mint 13 - Ubuntu 12.04 LTS derivative) to my 2007 Dell Inspiron 1501 with no problems.

With this new Lenovo Z585 I have learned about this new fangled thing called UEFI which has caused a STEEP learning curve on my part.

After many hours of searching & reading, I have installed a spare 80GB HD in the Lenovo & using PartedMagic on a usb flash drive checked this drive & prepped for a 2 OS install. (I have seen too many post about installs going bad.) I have loaded & have functioning Windows 7 Home Premium from a usb flash drive on this 80GB drive.

Now my problem(s): Using the 64bit LM13 install on usb, I get the beginning splash screen, hit enter to go to the menu choices of running LM13 etc. When I hit enter, I get the proverbial blinking cursor. I have gone into the bios & disabled UEFI before starting any of this.

I have tried a Live CD. I have also taken the USB & tried it on a desktop. It worked fine & picked up the network right out of boot up.

The bios on this Z585 leaves a lot to be desired. Can anyone give assistance?

I have read multiple threads on UEFI problems, but specific information for the Z585 is lacking. I have tried searching for info on the bios with little success.