I have been searching for an answer before posting this question that seems trivial.

I just bought an Asus Zenbook Prime UX31A-R4003P with Windows 8 Pro on it.
My aim is to install Ubuntu on it but so far I was not able to boot from a Live USB.

I tried to boot with the ordinary ubuntu-12.10-desktop-i386 version and soon found out that because the laptop was now using UEIF and not the BIOS type I used to know.
So I followed the instruction found here: https://help.ubuntu.com/community/UEFI and created a Live USB with ubuntu-secure-remix-12.10-64bits.iso.

I managed to boot on the USB on the UEIF mode by pressing ESC just after the laptop started. I arrived on the the screen with the four options: Try, Install, OEM and Check.
After pressing Enter with any of the options nothing happens. The screen stays blank (or black).
I tried the USB Key on another computer (BIOS type) and it worked fine.

Here is what I tried but still with no success:
- I changed 'quiet splash' to 'nomodeset' in the file boot/grub/grub.cfg on the USB drive.
- I used another USB drive
- I used ubuntu-12.10-desktop-amd64.iso.
- I used ubuntu-12.04.1-desktop-amd64.iso. Here I got a red warning: "Invalid signature detected. Check Secure Boot Policy in Setup"

If you have any more ideas to do the "simple" step 1: Boot Ubuntu from a Live USB, I would be glad to try it.

Thank you for any help.

Flash Type: Winbond 25X/Q Series
Current BIOS Platform: UX31A
Version: 214
Build Date: Aug 28 2012

Here is the other link I read: