I'm trying to determine whether or not my mic is working at all so that I can get it to work with Rosetta Stone. When I hit record on Audacity (1.3.13), I just see the cursor, no sound waveform. I checked alsamixer; my master volume and mic volume are turned up and not muted. I can hear myself in the mic. I tried following the audacity recording troubleshooting guide entry for "No waveform recorded behind the cursor," (using the legacy versions of Audacity section), but the first step describe a preferences screen setup that is different than mine (there are not tabs at all). That guide is here:

In Audacity preferences, I've tried setting my Recording Device to both default and HDA Intel PCH: ALC665 Analog (hw:0,0), with no difference.

I tried the stickied Sound Troubleshooting Guide, which led me to enter alsamixer and hit F4 to get to the recording settings. According to the picture here: https://docs.google.com/document/d/1iTlJ8BfqXUjaHO__TEdlkvuqB1WLOkGaudngc5SFLMI/edit?pli=1#heading=h.pfacsnwrf0cp

my settings are different. Instead of Front Mic Boost, Capture, Capture 1, and Input Source, I have Mic Boost, Capture, Capture 1, and Digital.