For that matter, you could install Mate or Cinnamon on Ubuntu. If you use 12.04, you shouldn't need to upgrade until 2017.