Results 1 to 2 of 2

Thread: 12.04 fails to boot

  1. #1
    Join Date
    Dec 2007
    Jyväskylä, Suomi Finland
    Ubuntu 12.04 Precise Pangolin

    12.04 fails to boot


    I was recently using 12.04LTS when without notice it went into a "hanging" state.

    I waited minutes for a recovery but nothing happened. So I performed the famous REBOOT procedure.

    I turned my laptop "OFF", and then I powered my laptop "on" AND this time a window I have never seen before appeared. See the attached image labelled "1". At this point, the reader should note that when powered "on" my laptop always booted straight to the login screen. Nothing more needed to be done than power on the unit.

    In case you can't see clearly the attachment in image "1" it states:

    GNU GRUB version 1.99-21ubuntu3.4

    Ubuntu, with Linux 3.2.0-32-generic
    Ubuntu, with Linux 3.2.0-32-generic (recovery mode)
    Previous Linux Versions
    Memory test (memtest86+)
    Memory test (memtest86+, serial console 115300)

    use the "up arrow key" keys to select which entry is highlighted.
    Press enter to boot the selected OS, 'e' to edit the commands before booting or 'c' for a command-line.

    I highlighted the first option "Ubuntu, with Linux 3.2.0-32-generic" and received the effects as presented in attachment "2".

    Highlighting the second option eg "Ubuntu, with Linux 3.2.0-32-generic (recovery mode)" yields the same result.

    Moving on to the third option "Previous Linux Versions", gives me a list of all the ubuntu versions. For example: Ubuntu, with Linux 3.2.0-31-generic BACKWARDS to "Ubuntu, with Linux 3.0.0-17-generic. Each version has a supported "recovery mode" option as well.

    If we choose "Ubuntu, with Linux 3.2.0-32-generic" then the same result appears as depicted in attachment "2"

    What is the best way to go about correcting this issue?


    Attached Images Attached Images

  2. #2
    Join Date
    Dec 2007
    Jyväskylä, Suomi Finland
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 fails to boot

    I solved my problem!

    For anyone else this might help .... bear in mind the following.

    I have a Panasonic Toughbook CF-29. It has 12.04LTS installed. HOWEVER,

    When attempting to install 12.04 from normal Live CD's this isn't gonna happen if you get this error message:

    This kernel requires the following features not present on the CPU:

    Unable to boot - please use a kernel appropriate for your CPU

    That said, other methods are followed when installing 12.04,e.g.:

    What I did is I got a 10.04 cd and followed the following:

    1. At keyboard and stickfigure hit "enter"
    2. Now press F6 followed by ESC
    3. Enter i915.modeset=1 This is entered after quiet splash.
    4. press enter

    Once the 10.04 live cd is running I performed the following:

    1. LiveCD / LiveUSB (my preference)
    2. Dash -> Disk Utility
    3. Mount Volume (try this first, if it mounts skip to #6 otherwise go to #4)
    4*. Check FileSystem (this will run a check and repair anything it needs to)
    5*. Mount Volume (second attempt, should work after Filesystem check if it didn't before)
    6. Close Disk Utility & Shutdown/Restart your computer.
    7. Remove the LiveCD (before shutdown) or the LiveUSB (after shutdown)
    8. Restart (may or may not go to GRUB menu, if it does choose the first option).

    *Note - steps 4. & 5. are only for if the first Mount Volume attempt fails.

    At step 8 I was lead to GRUB menu and thus choose the first option. Upon subsequent reboots the bootup went directly to login w/o and further input from Me


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts