Hello guys.

Hopefully someone knows a bit about the nvidia drivers. I am trying to install the drivers on a Lenovo Y580 that has a GTX 660M, running 12.04 64 bit. Everything I have tried results in the nvidia settings saying that "you do not appear to be using the nvidia x driver." I have downloaded the driver directly from nvidia and installed it, and I have done the following also.

Code:
sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current
I have ran the
Code:
nvidia-xconfig
but that does absolutely nothing, still results in the settings saying that I am not using the nvidia x driver. Also my resolution is stuck on 640x480 with the drivers installed. It goes back to the native 1920x1080 after I uninstall them.

I have also tried out the bumblebee drivers... and they didn't work. Though that was something else entirely. I know there are a lot of threads out there with this kind of problem, but I just have not been able to come across anything that helps.
Any suggestions or help any has to offer I greatly appreciate.

The driver that I have tried using is the 304.64 driver. The latest stable one.

Thanks