No problem ! It's fun !

I actually pointed you to post #62. The one you tried is for a different product. Plus, you also had to replace the vendor/product IDs with yours. Sorry it confused you.

To avoid further confusion, please do EXACTLY as described below (a shameless copy-paste with relevant changes from alexfish's post.).

In a terminal, enter (keep the terminal running during this entire process) -
Code:
sudo su
gedit /usr/bin/option_07d1:7e11
Add the following lines in the file opened in gedit (you may simply copy-paste wherever possible)-
Code:
#! /bin/bash
echo 07d1 7e11 > /sys/bus/usb-serial/drivers/option1/new_id
Proofread, save and close gedit.

Then in the same terminal, run -
Code:
chmod +x /usr/bin/option_07d1:7e11
gedit /etc/udev/rules.d/option.rules
Add the following lines in the new file opened in gedit -
Code:
ATTRS{idVendor}=="07d1", ATTRS{idProduct}=="7e11", RUN+="/sbin/modprobe option"
ATTRS{idVendor}=="07d1", ATTRS{idProduct}=="7e11", RUN+="/usr/bin/option_07d1:7e11"
Proofread, save and close gedit. Also exit 'su' in the terminal -
Code:
exit
Then close the terminal as well.

Now plug-in your modem, and let us know if the magic works. Replug after a restart if required.