Okay, so at first, I installed 12.10 on my VAIO just fine. Brand new hard drive since the one that was in had my partitions all strange. I didn't want to deal with it so in went the new one. I installed all nice and good via USB(I feel this might have been the problem, but hear me out.)

It installed and worked perfectly good for a while. Then, it froze. I shut it down and back up. It froze again for a while. I ran a memcheck on the next boot and I have errors at Test#7 [random number sequence] EXACTLY at 43% (this is important). So I thought, darn, need to replace RAM. Oh well. *replace RAM and test again* Fails same exact spot. I think, DAMN! RAM SLOTS! *clean with rubbing alcohol and each slot individually* Both fail. I thought, well hell, I'm SOL.

NOW: I found my old laptop and powered Win7 perfectly fine and what not. I mess with it, then format and install Ubuntu 12.10 once again. Again, installs fine, works fine and BOOM! Freezes. Immediately ran the MEMCHECK and what do you know? Fails same exact spot as stated above. There's NO way I can be this unlucky. I mean, is it really my RAM, or did I do something wrong?

[This is my first time EVER messing with Linux in general.]