Hi all,

There is a situation I can't resolve myself or find anything similar anywhere.

When I try to log in from the first login form that comes up after successfully booting Xubuntu up, only a blank page with the standard wallpaper comes up, nothing else. Neither processor nor the hard drive does anything noticeable at that moment.

No matter if I choose Xfce or Xubuntu as sessions. When I check .xsession-errors, it contains a number of lines like:

Code:
No protocol specified
xprop:  unable to open display ':0.0'
Loggin via TTY doesn't work either. It displays an error:

Code:
xvinfo: unable to open display ':0.0'
There clearly is a problem only with my account as logging in as a guest is still possible. I've tried to remove .Xauthority or .ICEauthority but that didn't change anything.

The most likely cause of this issue is that I had an external monitor connected to my laptop through a display port and tried to suspend (put into sleep) the PC. It didn't come through and froze - I had to reset the computer. Since then the problem with logging in occurs. Connecting the monitor back before trying to log in doesn't help.

So the question is: Is there a way to reset which display should be opened upon a login?

Thanks a lot for any sort of help!