Quote Originally Posted by monkeybrain2012 View Post
I don't know, I clicked that link and it offered to download the deb so it works, maybe you can try again? Once download you can just install the deb by right clicking. The guy who posted the original solution was making it unnecessarily cryptic for new users with wget and dpkg -i and what not

Basically, download and install glib_2.06 which is a deb package.

Then follow the steps in installing 32 bit library and creating the symbolic link.

Seems that wine thinks that you are running 32 bit machine for some reasons.

EDITED: BTW if you want to install a .deb with the command "sudo dpkg -i .." you need to first cd into the directory where it is, so if it is on the desktop, you need to run 'cd Desktop'. This is a general rule: you have to do things in the correct directory.
i got an error in the second part.

The following i386 packages will be installed: gnome-keyring:i386
Continue [Y/n]? y
Downloading ...
Installing libraries ...
cp: target `/usr/lib32/' is not a directory
Copying files failed - run getlibs with "sudo getlibs" or as root
it worked fine the second time, but now i'm trying to install the 32 bit library, and after it worked for a while, when it tries to install it, i get an error (even though i did sudo getlibs from the beginning).

i tried this twice (sudo getlibs -p gnome-keyring:i386)