Quote Originally Posted by zelemo View Post

I've just upgraded from 12.04 to 12.10 and discovered a problem, which I solved myself after a couple of hours of scratching about - so I thought I'd post here in the hopes that someone else might find it useful.

On 12.04 (and several previous versions) I've had a /etc/fstab which does a few mounts to Windows and/or Samba servers using cifs (smbfs as was).

When I upgraded, I discovered on first boot that none of them worked. When I tried to mount manually, I got an error saying something like "bad sector block or other possible error - please do "dmesg | tail" to find out more."

So, I did a dmesg | tail and discovered the following errors:-

[ 432.864261] CIFS VFS: Connecting to DFS root not implemented yet
[ 432.864388] CIFS VFS: cifs_mount failed w/return code = -22

I'm going to cut a long story short. What happened was that, for some reason, the upgrade to 12.10 removed the old version of cifs-utils and didn't replace it with a new one.

I just did

sudo apt-get install cifs-utils

...and it all came back to life again.
You are my HERO