As I posted over on the "Suspend from sleep" thread I've got a G4 iMac set up to boot OSX & Xu/Lu 12.04 that has been hit with a plague of kernel panics, first it seemed like they were only happening in Xu/Lu, but then they started happening in OSX as well. I ran the Apple Hardware Test disk several times and it shows OK, I've repaired the disk with Apple's DU, and used Onyx to clean up the system, I've even installed a fresh OSX 10.4.6 on an Ext HD and booted from the Ext HD and the kernel panics continue. I'm thinking "hardware" but so far nothing has shown to clearly show that. Would there be some Ubun/Linux tool that could analyze the system such that it might point out what the problem is? A GUI app might be better for me, but if a CLI app is out there that could be tried with a little help from the forum . . . that would also work. I'd like to keep the iMac going, it's got ten years of data and it serves to check email and get around the web well enough. Any thoughts?

Last post from the other thread from earlier in the month, no replies offered:


Appreciate the follow-up, just letting you know the latest situation, looks like my horsie is again pulling up lame and will be a DNF once again. I just tried to boot the Xu 12.0.4 system to check on lsmod and wound up with multiple problems, problems getting Yaboot window to show up, problems getting gdm log in window to stay, problems with once getting passed gdm log in then mouse didn't work and no toolbar, problems then getting passed xubun splash window with subsequent kernel panic, problem with kernel panic before the Yaboot window . . . problem with showing a single user window that wouldn't accept my password to get into CLI . . . went thru 5 cold boots essentially ending in kernel panic. Gave up, when I tried to boot OSX, there also was a kernel panic and had to restart . . . thought it might be the old iMac giving up its life force, but seems like it's OK for now . . . don't know why kernel panics in Xubun would carry over to OSX? But, this has been the history of trying to get anything in the Linux realm to run on the iMac for longer than a few months, seems to be doing OK, then the system seems to start degrading?? kernel panics start and eventually the CLI even goes away. There was something about "starting pbbuttonsd 0.7.9 Unknown powerbook; speech-dispatcher disabled, edit; starting NTP-server-ntpd-kernel panic 3 or 4" on the Xubuntu splash window.

I did do an update/upgrade on Friday night, couple night back using "sudo aptitude" and I rebooted then and everything seemed to be OK, I can't remember if I installed "powerprefs" in the iMac following a comment in the PPC FAQ about either getting suspend to work, but I didn't adjust anything in the GUI powerprefs window when it opened . . . so I don't know if somehow one of the upgrades has messed with my "nv" driver compilation . . . but once again there is a problem. Seemed like Xu/Lu 12.0.4 got me closer to something stable . . . will have to see on another day if I can get it working, if it's a hardware issue, or just try what will be the 6th or 7th re-install . . . . Maybe Tuesday I'll again have a moment to play around . . . the sound issue goes to the back burner for now.