Results 1 to 5 of 5

Thread: LBL 3300 Printer Driver

  1. #1
    Join Date
    Feb 2010

    Exclamation LBL 3300 Printer Driver

    I have installed UBUNTU 9.10, when i tried to install CANON LBP 3300 printer i am unable to get the printer drivers. I have searched on the forums and found some links regarding this.

    They askked me to download some .tar file and install it, i have tried so...

    The printer is installed but when i tried to get the printouts the job status it is showing as print is under processing.\

    I have waited for long time, but unable to get the prints...

    can Anybody suggest the process to install the Printer of CANON LBP 3300 and get the prints.

  2. #2
    Join Date
    Dec 2008

    Angry Re: LBL 3300 Printer Driver

    I got the same problem.

  3. #3
    Join Date
    Oct 2012

    Unhappy Re: LBL 3300 Printer Driver

    Hell yeah.
    I have the drivers. Everything is ok except it won't print.
    The jobs are sent to the printer, processed then nothing happens.
    I am using Ununte 12.04 TLS 64BIT version.
    I want to uninstall sorry. I have tried everthing on the internet.
    Nothing works.

  4. #4
    Join Date
    Jul 2012

    Re: LBL 3300 Printer Driver

    I am not familiar with canon printers, but if indeed they are incompatible with
    ubuntu you can post that here and help everyone,

    Desktop Hardware Incompatibility List.

    Before you do that though perhaps you could search the threads under
    canon printer, if you haven't already.

  5. #5
    Join Date
    Apr 2005

    Canon LBP 3300 Printer Driver

    you sound very fed up .........

    you say LBL .............but you mean LBP ........??

    can we check the drivers are installed fine .......

    can you copy and paste this command

    sudo dpkg -l | grep Canon
    .......and copy and paste the results back ............

    and also what do you get with

    captstatusui -P LBP3300
    __________________________________________________ _______________

    If the drivers are installed, the next steps should be:

    2. Register the printer

    sudo /usr/sbin/lpadmin -p LBP2900 -m CNCUPSLBP3300CAPTK.ppd -v ccp://localhost:59787 -E Ubuntu 12.04 it is said ........"Ubuntu 12.04 has again blacklisted the usblp module"..........I didn't find this to be so with Mint, so my printer works by ignoring this ubuntu-specific advice...........

    In post #4 of this thread

    Sivella, who is very good on the LBP continues the story that I have described above:

    3) Register the printer with ccpd daemon:

    sudo /usr/sbin/ccpdadmin -p LBP3300 -o /dev/usb/lp0

    4) Start ccpd daemon:

    sudo /etc/init.d/ccpd start

    5. Test the install:

    captstatusui -P LBP3300

    will open the Statusmonitor window. If the message "Ready to print" is displayed --> all is OK.

    Try to print something.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts