Hello there, I am new to the forums and kind of new to the world of Ubuntu. I installed it on my last laptop, but never got around to playing with it. Well that laptop died with a gaint foot.

So, I bought a Asus K53e! As soon as I turned it on, there was no OS. It only costs 200 dollars. Can't complain.

So, i placed Ubuntu 12.10 on here. I plugged it into a Ethernet line while installing the ubuntu 12.10 64-bit. The Asus K53e has 8 gb of ram and an I-5 processor.

After a fresh install and a update, i tried to play on my laptop elsewhere and found that my wireless doesn't work correctly. It will connect, but only for 2-4 minutes.

I have searched the forums and tried many of the different things that was said. I noticed a common trend was the update, but that is done and the wireless is still giving me troubles. I also set the wireless to all users. But I have no idea what i am doing wrong.

Inorder to upload this ^. I will have to disconnect and reconnect. The Asus K53e from my understanding have all had this same problem.

So, is there a fix?