ubuntu automagically mounted things to /media
in my experience

turns out my external drive is not mounted:
Code:
> mount
/dev/sda9 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
overflow on /tmp type tmpfs (rw,size=1048576,mode=1777)
gvfs-fuse-daemon on /home/frank/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=frank)
/dev/sda10 on /media/LOCAL_HD type ext4 (rw,nosuid,nodev,uhelper=udisks)
I'm pretty sure this is what happened:
I tried to get (let's just call my ext drive hitachi) hitachi to mount automatically through fstab - that's a fact, I don't know what that has to do with this.

Guessing: At some point Deluge didn't see hitachi and created its own files as its default path is /media/HITACHI then it started downloading and filling my hard drive. Because going through the files, there are dozens of empty folders and the only real files are recent downloads. though there are 3 folders there that Deluge has nothing to do with.

Well I'm going rm the files and the plug my hitachi back in and see what happens.