Althought this is Ubuntu's forum, but since it worked on Mint too, I would like to ask for your help.

So I am trying to install Mint on my new Dell Laptop. When I click on "Install Linux Mint" on the desktop and the window opens and asks me to choose language, etc... However It doesn't let me choose If I wanna "install along with windows" or " Remove OS and install Linux" or warever those choises are... It straight ahead goes to the partitioning table and for some reason doesn't show my partitions. GParted, on the other hand, shows the partitions.

Now surprisingly I had the same problem on my desktop pc and I found the solution here:
It says it has to do something with RAID metadata. Now when I tried the solution it worked fine.

Now my Dell laptop has a 500 GB HDD + 32 GB SSD Cache (notice its cache not a normal SSD).
Now I know so little about Linux and little about SSD's (especially cache) so I am not sure If I should apply the same fix on my laptop. Maybe there is a RAID connection between the HDD and the SSD that with that code might stop working. Is this even the right solution for my problem?

Hope someone can help... Thanks in advance

Installation window:

*Notice also that the installer only detects the sdb (SSD cache)

500 GB HDD:

32 SSD cache: