Results 1 to 4 of 4

Thread: Wrong credentials for GUI

  1. #1
    Join Date
    Jan 2009

    Wrong credentials for GUI

    I think this is a bug, but wanted to confirm here first.

    I have two accounts on machine - first one was created when I built the machine and is part of sudo group.

    Other account is coming from active directory, this account also has admin permissions - that is it can execute commands using sudo. This is my normal work account and I do execute sudo commands all the times from terminal.

    However if I run some GUI application that needs sudo permissions - e.g. ubuntu software center application to install new software, my active directroy password does not work. It just asks me the password, but password it needs seems be that of default login and not active directory login. I have noticed same thing happening with other GUI applications that need authentication aslo.

    Is there possibility that GUI sudo authentication and terminal authuntication are following different pahs? Terminal sudo authentication does work as expected if I enter my active directory password.

  2. #2
    Join Date
    Jul 2005
    I think I'm here! Maybe?

    Re: Wrong credentials for GUI

    Forgive me if you are aware of this, but GUI applications do not, or should not, use sudo. They use gksu or gksudo in gnome or other gtk DEs such as Xubuntu and Lubuntu, and kdesu in KDE or other QT DEs, eg razor-qt.
    Last edited by ajgreeny; October 11th, 2012 at 11:43 PM.
    DISTRO: Xubuntu 16.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

  3. #3
    Join Date
    Sep 2010
    Central Calif
    Xubuntu 12.10 Quantal Quetzal

    Re: Wrong credentials for GUI

    but password it needs seems be that of default login
    Software, etc needs the login password for the user that logged in for that session. You do know that you do not add 'sudo' to those types of authentication? Just the password.
    Last edited by critin; October 12th, 2012 at 01:16 AM.
    Remember When Double-Dog dare ya's and water balloons were the ultimate weapon?

  4. #4
    Join Date
    Jan 2009

    Re: Wrong credentials for GUI

    I see I created some confusion in terminology. What I meant was when the program needs to elevate the previlages whether from terminal or from UI.

    Here is example of what I mean.

    From terminal prompt if I type the command

    sudo apt-get install <some package I need>

    This asks me for the password. The password I enter is for my current login. And this works.

    Now if I go to ubuntu software center and try to install something I want, it asks me for the password. If I enter my current password here (which worked on above case), it does NOT work. I have to enter password for the default login.

    So the question is why does terminal pervilage elevation accept my password and GUI based applications do not

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts