Results 1 to 2 of 2

Thread: Samsung 900X4C, keyboard backlit command in boot

  1. #1
    Join Date
    Oct 2012

    Samsung 900X4C, keyboard backlit command in boot

    I have a new samsung 900X4C and have installed ubuntu as single OS (12.0.4 LTS and today I have upgraded the kernel to 3.4.1-030401-generic).
    I'm very happy with the computer and everything works ok, except some Fn keys like Fn+F9/F10 (keyboard backlit) and F12 (wireless is always on - I can turn on/off only with command line) and F11 (the same problem).
    Today I've upgraded the kernel to 3.4.1-030401-generic and so I've solved the problem of keyboard backlit. Now, with this kernel, I can turn on/off the keyboard backlit with the command
    sudo echo 4 > /sys/devices/platform/samsung/leds/samsung::kbd_backlight/brightness
    The values can be between 1 and 8.

    Note: it's not enough sudo... to work I have to put su before

    mp@mp-900X4C:~$ sudo echo 4 > /sys/devices/platform/samsung/leds/samsung::kbd_backlight/brightness
    bash:/sys/devices/platform/samsung/leds/samsung::kbd_backlight/brightness: Permissão negada
    mp@mp-900X4C:~$ su
    root@mp-900X4C:/home/mp# sudo echo 4 > /sys/devices/platform/samsung/leds/samsung::kbd_backlight/brightness
    (and it works)

    Why do not work with sudo? It's not the same thing??

    Then I have tried to execute the command in boot. I try to solve this in two possible ways:

    I have put the command in rc.local (/etc/rc.local or /etc/init.d/rc.local).

    echo 4 | sudo tee /sys/devices/platform/samsung/leds/samsung::kbd_backlight/brightness
    echo 0


    sudo echo 4 > /sys/devices/platform/samsung/leds/samsung::kbd_backlight/brightness
    echo 0

    I have changed the permisions obviously
    sudo chmod +x <file_name>

    and none works!!!! It seems that the file is ignored in boot

    I have created the script


    echo 4 | sudo tee /sys/devices/platform/samsung/leds/samsung::kbd_backlight/brightness

    and then I have created a symbolic link in /etc/rc2.d/ --> /etc/init.d/

    and then again in reboot doesn't work(((

    it seems the a simple problem but I can not do it work...

    Can you help me please...
    Last edited by marcoperez; October 11th, 2012 at 01:17 AM.

  2. #2
    Join Date
    Jul 2007
    Magic City of the Plains
    Xubuntu 17.10 Artful Aardvark

    Re: Samsung 900X4C, keyboard backlit command in boot

    Post moved to its own thread.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts