Hi
I'm using Processing.org which has an IDE (called a PDE) that compiles Java applications, so I'm not using Eclipse (or other IDE). Processing just got built-in support for gstreamer so I'm just simply trying to load a movie into a sketch (processing compiled java application). But I keep getting this error
Code:
Exception in thread "Animation Thread" java.lang.UnsatisfiedLinkError: Unable to load library 'gstreamer-0.10': libgstreamer-0.10.so: cannot open shared object file: No such file or directory
    at com.sun.jna.NativeLibrary.loadLibrary(NativeLibrary.java:163)
    at com.sun.jna.NativeLibrary.getInstance(NativeLibrary.java:236)
    at com.sun.jna.Library$Handler.<init>(Library.java:140)
    at com.sun.jna.Native.loadLibrary(Native.java:379)
    at org.gstreamer.lowlevel.GNative.loadNativeLibrary(Unknown Source)
    at org.gstreamer.lowlevel.GNative.loadLibrary(Unknown Source)
    at org.gstreamer.lowlevel.GstNative.load(GstNative.java:42)
    at org.gstreamer.lowlevel.GstNative.load(GstNative.java:39)
    at org.gstreamer.Gst.<clinit>(Gst.java:59)
    at processing.video.Video.initImpl(Unknown Source)
    at processing.video.Video.init(Unknown Source)
    at processing.video.Movie.initGStreamer(Unknown Source)
    at processing.video.Movie.<init>(Unknown Source)
    at movtest.setup(movtest.java:30)
    at processing.core.PApplet.handleDraw(PApplet.java:2103)
    at processing.core.PGraphicsJava2D.requestDraw(PGraphicsJava2D.java:190)
    at processing.core.PApplet.run(PApplet.java:2006)
    at java.lang.Thread.run(Unknown Source)
the code is pretty simple cause it's just basically an example file included with processing
Code:
/**
 * Loop. 
 * 
 * Move the cursor across the screen to draw. 
 * Shows how to load and play a QuickTime movie file.  
 *
 */

import processing.video.*;

Movie movie;

void setup() {
  size(640, 360);
  background(0);
  // Load and play the video in a loop
  movie = new Movie(this, "transit.mov");
  movie.loop();
}

void movieEvent(Movie m) {
  m.read();
}

void draw() {
  //if (movie.available() == true) {
  //  movie.read(); 
  //}
  image(movie, 0, 0, width, height);
}
I've tried other variations of this code but still get the same error. Any idea why it's doing this? If this is a problem with symlinking or something else please could u tell me how to fix it, I really need some help here!