Ok so the basic issue here is this: My wireless has not once enabled through many environments.

Wubi install: Enable wireless greyed out

Live cd: greyed out

Partition alongside win7: greyed out.

I installed all software updates, checked additional drivers, installed the latest driver for RTL8111/8168B.

rfkill list shows phy0 and phy1.

Phy0 has a hardblock on. everything else is unblocked.

Now consider this also: I have both a wireless adapter inside my laptop and a wireless usb adapter outside. The internal adapter does not work, hence why I think hardblock is on even if the external slider in 'on'.

I have tried commands such as rfkill unblock all as well as sudo rfkill unblock all.

No wireless options in the BIOS.

I have tried another laptop and desktop and they get wireless from the get go.

Ubuntu on my laptop seems to see my belkin adapter as well as my internal (ralink) one. But trying to scan networks yields no results and says network is down always.

Ubuntu version: 12.04 lts

Ask me anything else you may need to help me, thanks.