Results 1 to 5 of 5

Thread: Wifi Hotspt in Ubuntu 11.10

  1. #1
    Join Date
    Mar 2012
    Beans
    1

    Wifi Hotspt in Ubuntu 11.10

    I am using Ubuntu 11.10 along with Windows 7. I use a mobile broadband to connect to Internet. I have couple of Android phones which need Wi Fi access as well. In windows, i use Connectify.

    But in ubuntu, when i create a wireless connection as hotspot from Network, any other device fail to recognize that hotspot. Please help with detailed instructions.

    regards,
    Shuvabrata

  2. #2
    Join Date
    Oct 2006
    Location
    Florence, Italy
    Beans
    170

    Re: Wifi Hotspt in Ubuntu 11.10

    Th problem might be that Android phones only connect to "infrastructure", not "ad hoc", networks. So I read somewhere, sorry that I can't be more specific.

  3. #3
    Join Date
    Jan 2012
    Beans
    12

    Re: Wifi Hotspt in Ubuntu 11.10

    hi to all ...
    here i explain the method very simply... if u ll succeed do enjoy .....
    hi i tried the method and it’s ok 100%
    i again give the right tutorial …though the author is right always..
    follow this…..====>
    Just run this in the terminal:

    sudo apt-get install hostapd
    u ll get install hostapd (though u can’t see in DASH HOME)
    OK NOW..
    Then, open a text editor program, for example gedit. Copy the following into it.
    that means open — gedit —from DASH HOME
    TYPE THE SAME WITH SOME CHANGES….
    =======================================

    interface=wlan0
    driver=nl80211
    ssid=
    channel=1
    hw_mode=g
    auth_algs=1
    wpa=3
    wpa_passphrase=
    wpa_key_mgmt=WPA-PSK
    wpa_pairwise=TKIP CCMP
    rsn_pairwise=CCMP
    =======================================

    KEEP IN MIND THAT IN ABOVE LINES…..
    ssid= (is your network provider, e.g. mine is reliance EVDO)
    SO I MODIFY ABOVE LINE AS THIS….

    ssid=reliance EVDO
    NOW
    wpa_passphrase= (is your desired password, e.g. mine is maulesh)
    SO I MODIFY ABOVE LINE AS THIS….

    wpa_passphrase=maulesh
    OK NOW DO THIS …AND SAVE FILE GENERATED IN gedit…
    AS NAME —– hostapd.conf (IN YOUR HOME DIRECTORY)
    OK NOW U FINISHED ONE PHASE TO MAKE YOUR UBUNUTU MACHINE VIRTUAL ROUTER….


    THE SECOND PHASE IS MORE IMPORTANT … (IF U FOLLOW OR UNDERSTAND ME CORRECTLY… THEN U WIN)


    NOW OPEN — network — from DASH HOME
    GO TO OR OPEN — wireless —-
    (see if wireless is ON or not …if OFF then ON it…)



    NOW PUT YOUR MOUSE CURSER TO THE RIGHT CORNER OF THE SCREEN AND CLICK … U SEE MANY NETWORKS THERE…
    CLICK
    — create new wireless network — U LL SEE A NEW WINDOW AS THIS (I CAN’T DRAW SO SEE AS BELOW)
    NEW WIRELESS NETWORK
    CONNECTION (NEW)
    NETWORK NAME (BLANK)
    WIRELESS SECURITY (WEP 128-BIT PASSPHRASE)
    KEY (BLANK)

    (CANCEL) (CREATE)
    NOW FOLLOW ME>>>>


    CONNECTION (NEW)
    NETWORK NAME (your network name -as in hostapd.conf) ((for me reliance EVDO))
    WIRELESS SECURITY (WPA & WPA2 PERSONAL) ((only select this to protect ur connection))
    KEY (your desired password -as in hostapd.conf) ((for me maulesh))
    NOW CLICK (CREATE)
    OK OK WAIT… JUST FOR SECONDS….
    AGAIN PUT YOUR MOUSE CURSER TO THE RIGHT CORNER OF THE SCREEN AND CLICK … U SEE MANY NETWORKS THERE…
    CLICK

    — connect to hidden wireless network — U LL SEE A NEW WINDOW AS THIS (I CAN’T DRAW SO SEE AS BELOW)
    CONNECTION (NEW)
    NETWORK NAME (BLANK)
    WIRELESS SECURITY (BLANK)

    (CANCEL) (CREATE)
    NOW CLICK ON CONNECTION … U LL DEFINITELY SEE YOUR CONFIGURED WIRELESS NETWORK (for me — reliance EVDO– )
    OK NOW SELECT UR CONFIGURED NETWORK AND CLICK
    (CONNECT)


    SO U VE NOW COMPLETED THE SECOND AND MOST IMPORTANT PHASE)


    JUST A FEW MINUTES TO OBSERVE OR CHECK WE R RIGHT/WRONG SO ..


    GO TO — terminal — from DASH HOME
    GIVE THIS COMMAND …. (don’t close this terminal until u r using network on other machine)


    sudo hostapd hostapd.conf


    AND NOW THE TERMINAL DANCE… N WE DANCE TOGETHER …
    CHECK UR WIFI — in tablet or pc….
    U LL NOTICE THE CONFIGURED NETWORK OPEN FOR U TO SERVE U BETTER ALWAYS…..
    BYE… THANKS FOR FOLLOW ME….
    my email is —- elc12thsep00@yahoo.co.in

    and of course very very fond of LINUX UBUNTU …. and its USERS…..
    THX…T.C….BYE….



  4. #4
    Join Date
    Dec 2008
    Beans
    250
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Wifi Hotspt in Ubuntu 11.10

    Thanks a lot man, this seems to work after all the efforts I had earlier. The important part was setting a wireless connection in NM.

  5. #5
    Join Date
    May 2008
    Location
    Usually northern Thailand
    Beans
    193
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wifi Hotspt in Ubuntu 11.10

    Thanks for this article. It's the best I've found so far. but I'm still not able to pass any traffic through the new wifi link I've set up.

    I can see the wifi SSID I've created on my laptop appearing as a signal on both my symbian phone and my android. They both prompt me for my network key which I've given them, and then they try to obtain an IP address, but this seems to be where they're failing. No successful login

    Meanwhile I'm seeing the following regularly repeated in Terminal:

    Code:
    wlan0: STA b8:d9:ce:f6:14:76 IEEE 802.11: authenticated
    wlan0: STA b8:d9:ce:f6:14:76 IEEE 802.11: associated (aid 1)
    AP-STA-CONNECTED b8:d9:ce:f6:14:76
    wlan0: STA b8:d9:ce:f6:14:76 RADIUS: starting accounting session 50725710-0000001E
    wlan0: STA b8:d9:ce:f6:14:76 WPA: pairwise key handshake completed (RSN)
    AP-STA-DISCONNECTED b8:d9:ce:f6:14:76
    wlan0: STA b8:d9:ce:f6:14:76 IEEE 802.11: disassociated
    wlan0: STA b8:d9:ce:f6:14:76 IEEE 802.11: deauthenticated due to inactivity
    On a previous attempt before I tried with hostapd, I did manage to create an ad hoc signal acceptable to my symbian phone using the simple basic Hotspot facility, and using that I was able to successfully make a VOIP internet call on that phone, but that ad hoc signal didn't show up at all on my android.

    For some reason this hostapd setup doesn't appear to be supporting DHCP when I've configured for "infrastructure"

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •