Dear All,
I wonder whether anyone can help with this problem?

I have been provided with a SafeXs memory stick from work. It's encrypted. According to the producer 'Softek', it is usable in linux. One simply needs to copy the following line '%users ALL = NOPASSWD: /media/safestick/safestick' into sudoers and it should work.
I have tried this using sudo visudo as was recommended on a few forums. Then ctrl+X and then Y to save. In fact, because of the error message I was getting as shown below, I exchanged the 'safestick' bit of the line for 'SafeXs'.
Despite this, when I click on the SafeXs.exe file that I see when I open the usb drive, I continue to get the same error message:

Archive: /media/SafeXs Login/SafeXs.exe
[/media/SafeXs Login/SafeXs.exe]
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
note: /media/SafeXs Login/SafeXs.exe may be a plain executable, not an archive
zipinfo: cannot find zipfile directory in one of /media/SafeXs Login/SafeXs.exe or
/media/SafeXs Login/, and cannot find /media/SafeXs Login/SafeXs.exe.ZIP, period.

I have tried using it via WINE. It looks promising initially but the little password box that pops up simply says 'waiting for safeXs' and nothing happens.

I have tried opening it with archive manager, autorun prompt....nothing works.

Have I made the sudo adjustments incorrectly? Is there something I am missing?
Any advise gratefully received