Results 1 to 1 of 1

Thread: USB hard drive is not recognized.

  1. #1
    Join Date
    Sep 2008

    USB hard drive is not recognized.

    My Thinkpad T510 laptop can't see or recognize my USB 1.5 TB Toshiba hard drive. It worked fine till yesterday. I have Ubuntu 12.04 and Windows 7 installed on different partitions, and even Windows 7 can't see the drive. Strange thing is, that it works with 3 of my other computers at home. One of them running Windows 7, one Ubuntu and one Lubuntu. You just plug it in and it works. I wasn't doing nothing special like updating or installing something when it happend. Tried to run lsusb, fdisk -l and there is no sign that drive is connected even when it is. Disc utility or Gparted can't see it either. I changed the name and UUID, no help. I can't format it because I dont have such a big backup drive and it is almost full. Tried all usb ports. I don't understand how its possible that it works with other computers exept mine. Thank you for any ideas or help.

    Update: I tried different usb drive and usb stick and they work fine with my computer. Still can't see my Toshiba drive though.
    Last edited by cooco; October 7th, 2012 at 12:53 PM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts