Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Brightness problem in Ubuntu 12.04 64-bit

  1. #1
    Join Date
    May 2009
    Location
    Bangalore
    Beans
    103
    Distro
    Ubuntu 13.10 Saucy Salamander

    Brightness problem in Ubuntu 12.04 64-bit

    Hi All,

    In my Dell xps laptop, brightness is not getting changed. Pressing the on-board key or brightness setting will increase/decrease the brightness bar in top corner. But no effect is seen on the screen. Brightness remains same and after a reboot the brightness bar resets to maximum.

    I have installed Bumblebee to activate Nvidia. But this wont matter I guess as this issue is observed even before installing bumblebee.

    Any suggestions?



    Specs:

    Ubuntu 12.04 LTS 64-bit
    4 BG ram
    i5 480M processor
    Nvidia 420M 1GB graphics card.



    Thanks,
    ksprasad

  2. #2
    Join Date
    May 2009
    Location
    Bangalore
    Beans
    103
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Brightness problem in Ubuntu 12.04 64-bit

    Hi,

    I tried lot of solutions suggested by various people. None of them worked for me. When I used the function keys, the value in '/sys/class/backlight/acpi_video0/brightness' was getting changed but screen brightness was not changing.

    Finally got it solved with following method:

    Code:
    xrandr --output LVDS1 --brightness 0.5
    Got it from the following thread:

    http://ubuntuforums.org/showthread.php?t=1907928&page=5

    Regards,
    ksprasad

  3. #3
    Join Date
    Aug 2012
    Beans
    3

    Smile Re: Brightness problem in Ubuntu 12.04 64-bit

    Quote Originally Posted by ksprasad View Post
    Hi,

    I tried lot of solutions suggested by various people. None of them worked for me. When I used the function keys, the value in '/sys/class/backlight/acpi_video0/brightness' was getting changed but screen brightness was not changing.

    Finally got it solved with following method:

    Code:
    xrandr --output LVDS1 --brightness 0.5
    Got it from the following thread:

    http://ubuntuforums.org/showthread.php?t=1907928&page=5

    Regards,
    ksprasad
    Hi, but the actual solution is not that. Its a great mess.

    When you try the xrandr --brigntness 0.5 to LVDS1, it will just decrease the Contrast value and will not save the power that you were expecting on the Ubuntu. You need to fix that permanently. So, hope to get that on on the Linux kernel or you can get help from here:
    With the solution mentioned on above link your (FN + Brightness UP/DOWN) both shall work on a single restart.
    Enjoy

  4. #4
    Join Date
    May 2009
    Location
    Bangalore
    Beans
    103
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Brightness problem in Ubuntu 12.04 64-bit

    Hi,

    Now only i saw your reply. Thanks for the suggestion. I didn't know that it will decrease only contrast. But earlier the screen was too bright and it was difficult to sit more than 15 mins and that way it worked for me.

    And off course i already tried the solution you mentioned and it did not work . May be after few kernel updates it might get resolved. Have to see.

    Regards,
    ksprasad

  5. #5
    Join Date
    Apr 2010
    Location
    Nova Scotia
    Beans
    54
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Brightness problem in Ubuntu 12.04 64-bit

    I use an HP Pavilion dm3 and had the same problem. Easy fix with the link given above:
    HTML Code:
    [url]http://www.techjail.net/solved-brightness-problem-in-ubuntu-12-04-precise-pangolin.html[/url]
    Thanks!

  6. #6
    Join Date
    Mar 2013
    Beans
    0

    Re: Brightness problem in Ubuntu 12.04 64-bit

    http://www.techjail.net/solved-brigh...-pangolin.html

    Thanks for the link, ksprasad.It corrects my Ubuntu 12.04 brightness control on a HP DV6 pavillion with Intel/ATI hybrid... Just perfect. Many thanks, again.

  7. #7
    Join Date
    Jul 2013
    Beans
    1

    Re: Brightness problem in Ubuntu 12.04 64-bit

    Hey I have found this : http://bit.ly/12pe6dp. Go to this link to adjust brightness this worked for me..

  8. #8
    Join Date
    Aug 2012
    Beans
    4

    Re: Brightness problem in Ubuntu 12.04 64-bit

    Quote Originally Posted by abugabbu View Post
    Hi, but the actual solution is not that. Its a great mess.

    When you try the xrandr --brigntness 0.5 to LVDS1, it will just decrease the Contrast value and will not save the power that you were expecting on the Ubuntu. You need to fix that permanently. So, hope to get that on on the Linux kernel or you can get help from here:

    http://www.techjail.net/solved-brigh...-pangolin.html

    With the solution mentioned on above link your (FN + Brightness UP/DOWN) both shall work on a single restart.
    Enjoy
    Thanks for this! I've tried several other solutions in the past, but this enabled my laptop's buttons to finally control screen brightness. Appreciate your help!

  9. #9
    Join Date
    Apr 2007
    Location
    Staunton, Va. USA
    Beans
    463
    Distro
    Ubuntu 15.10 Wily Werewolf

    Re: Brightness problem in Ubuntu 12.04 64-bit

    I tried the Techjail procedure and nothing happens and I don't even get the birghtness applet. So no brightness control and no appalet when pressing Fn right arrow or Fn left arrow (brightness down or up).
    This is on the Acer Aspire One 725 netbook (64-bit OS)
    How about another fix?
    System76 Lemur Laptop,12GB RAM,250GB SSD w/U16.04LTS
    White Box Computer:GigabyteGA-A75-UD4H MB,AMD A6-3670 APU,1TB SSHD, 16GB RAM,U14.04LTS
    AcerAspireOneNetbook725 6GB RAM,250GB SSD,U14.04LTS
    AcerAspireOneNetbookAO150,1.5GB RAM,120GB HD,U14.04LTS

  10. #10
    Join Date
    Aug 2012
    Beans
    4

    Re: Brightness problem in Ubuntu 12.04 64-bit

    No sooner had I gotten this working a couple of weeks ago in 12.04 and I decided today to blow up my Precise install and switch to 13.04. I can confirm that the Techjail procedure does not work (on my Gateway NV57H44u at least) in 13.04 64-bit.

    So, after some digging around I came across this solution instead. Using the following:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

    to replace the default line (which just ends in "quiet splash") in grub did the trick for me! I've read that it may work on other Ubuntu versions as well. Worth a shot!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •