I have a dual boot machine (Windows and recently installed Ubuntu 12.04) with several logical drives (formatted as ntfs) that I want to access in Ubuntu. When I use Nautilus, these all show up as “Devices” at the top of the left hand panel. When I select them, they are apparently automatically mounted, and an icon for the drive then appears in the left hand launcher panel of the desktop.


When I choose to [Restart] or [Shut Down], these “devices” seem to be automatically unmounted, and I can also manually unmount them by clicking on the button next to the drive name in Nautilus.


For various reasons, I wanted to have a few of these drives mount at startup, and I found many recommendations on how to add entries to /etc/fstab to do this. For example, I added the following lines to the file by “sudo gedit /etc/fstab”: …


Code:
/dev/sda5         /media/Development     ntfs    rw,user,auto        0       0
 /dev/sda7         /media/Genealogy         ntfs    rw,user,auto        0       0

… and the devices were indeed mounted at startup, and showed up in Nautilus with the “unmount” icon next to them as expected. So far, so good.


What I didn't expect was that, on shutdown, Ubuntu would almost shut down, but then “hang” after the desktop was long gone with only the text “Ubuntu” displayed in the center of the screen. I guessed (and this seems to be correct) that nothing was telling the drives to unmount automatically. So I powered off with the machine's reset button and rebooted.


Everything started nicely again, and I attempted to use the “unmount” icons in both Nautilus and the launcher panel before shutting down again, but was told that only root had permission to do this. Argghhh.


So, I used “sudo umount /dev/sda5” and “sudo umount /dev/sda7” and was then able to shut down normally without any hang-up.


So what magic option do I need to use to “cure” this user-hostile behavior? Do I need to have a user-only set of mount options that I have permission to unmount and, if so, how do I do that? I tried editing the /etc/fstab without sudo, but it won't permit me to save it.


Also, I really don't want the icons for these drives/devices or whatever to appear in the launcher panel, as they just take up space – it also seems less than useful to have them there since they look exactly alike and, with the need to poke the mouse around a fair bit to get the little call-outs to display that tell you what the icon represents (I presume that's a bug of some sort in Unity), these icons are not very useful. Is there a way to keep them from showing up in the launcher?


What I would really like is to have the drives I choose simply appear without any fuss under the section titled “Computer” (where the entries are Home, Desktop, Documents, and so forth). Can I simply have (for instance) my Genealogy partition (see sda7 above) appear in the list under Computer instead of Devices? I want them to feel like they're part of the family rather than being treated like lowly USB sticks !


One other thing (is this too many questions in one post?). Not unexpectedly, the partition that is the c:\ drive in Windows appears under Devices in Navigator. Is there a way to “hide” this to avoid inadvertently disturbing any files there, since all of my “data” files are located in other partitions?


Thanks in advance for any suggestions ...