My HP m6-1045dx laptop is barely a month old. I have Ubuntu 12.04 64 bit installed on it but I use the Awesome window manager instead of Unity.

About a two weeks ago I experienced a total system freeze twice, that did not respond to the magic sysrq keys either and I was forced to use the shutdown button. Both freezes occured when I was using Firefox, Chromium, and Google Chrome simultaneously.

Then it worked fine for two weeks until it froze three times yesterday and once today. Yesterday, I noticed that gimp was open each of the three times it froze, and once it froze while I was using the dolphin window manager, and once while opening a new tab among many others open in chromium. I uninstalled gimp and rebooted into recovery and ran fsck and other checks. But today it worked fine the entire day and then crashed again while opening a new tab in chromium while there were many others open. I think I remember this problem occurring ever since i installed google-chrome but not necessarily only when it is open, but to be on the safe side I have uninstalled google-chrome.

Each time the freeze occurs, the laptop does not respond to ANYTHING: neither the mouse nor Ctr+Alt+F1 nor the magic sysrq keys, even though the sysrq keys are enabled (I am able to use alt+Sysrq+K when the laptop is working normally).

I just updated the kernel to 3.2.0-30.

The laptop temperature always seems to be between 47 to 55 degrees and rarely crosses that.

I doubt any of this should be relevant, but just in case: also started using conky and recently shifted my /tmp to the RAM by mounting it as a tmpfs.

Please tell me if there is any code I can paste here to make it easier to diagnose.

Here is the part of the output of lspci -v that contains the graphics card information.

00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company Device 18a4
        Flags: bus master, fast devsel, latency 0, IRQ 44
        Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at b0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 3000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915
Thank you!