Quote Originally Posted by chili555 View Post
Woo hoo! That is awesome news! Great job.

As with any driver or module that's compiled from source code, it was compiled against your running kernel version only. When you get updates and get a newer kernel version, also known as linux-image, you will need to recompile:
Code:
cd Desktop/compat-wireless-3.5.1-1-snpc
make clean
./scripts/driver-select alx
make
sudo make install
sudo modprobe alx
You might copy these instructions to your desktop so you'll recall when the time comes.

The alx driver is a new arrival and you've worked out a successful install. So the searchers can find the fix, please use thread tools at the top and mark Solved.
I make note of your remarks concerning a newer kernel. Again, many thanks!