Hello I need help with a clean install on my brand new Gigabyte ga-990fxa-ud5. I bought the board and swapped all other components from my previous machine onto the new mobo. I had 12.04 installed on that system with no problems. So I know that it is not a driver issue with any other components except the motherboard.
I could not install ubuntu 12.04 in the new machine until I swapped the sata from the dvd drive from the sata II to the sata3. I would get busybox v1.18.5 (initramfs) unable to find a medium containing a live file system message. After swapping to sata3 I was able to install 12.04. Now it begins to load to the purple/brownish screen and hangs up before it gets to a login screen.
I tried changing in bios IDE to ACHI with no avail. I have pretty much tried everything the general google search suggest. It appears to be a motherboard issue please help. If you have witnessed a working 12.04 on this motherboard or have any ideas please let me know how it was done.

Here are my system specs just in case:
Gigabyte GA-990FXA-UD5
Phenom II x6 1090T @3.2GHz
Team Elite @ 1333
Sapphire HD6950 2GB ddr5
scythe 12 fan controller
I removed all external devices.