Results 1 to 5 of 5

Thread: Disable autostart apps

  1. #1
    Join Date
    Jul 2012
    Location
    /tropics/islands/statia
    Beans
    275
    Distro
    Kubuntu 12.04 Precise Pangolin

    Disable autostart apps

    I forgot to close my file manager once on logout from KDE, now it gets autostarted every time I log in to KDE. I only want my desktop widgets and Superkaramba apps to autostart. I already tried to save the session (System Settings - Startup and Shutdown - Session Management: Restore manually saved session) without the file manager, logging out, logging back in, but the file manager started again. How to make it stay away?

  2. #2
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Disable autostart apps

    Quote Originally Posted by Statia View Post
    I forgot to close my file manager once on logout from KDE, now it gets autostarted every time I log in to KDE. I only want my desktop widgets and Superkaramba apps to autostart. I already tried to save the session (System Settings - Startup and Shutdown - Session Management: Restore manually saved session) without the file manager, logging out, logging back in, but the file manager started again. How to make it stay away?
    Can you reverse the process given here?

  3. #3
    Join Date
    Apr 2011
    Location
    Maryland
    Beans
    1,461
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Disable autostart apps

    On my Kubuntu install, I found the restore session to be a bit flaky. Sometimes it just keeps opening stuff that I've closed just as you describe. If you don't want to manually add each item you want autostarted as Cortman suggests, you could try to change the selection to start new session, log out and back, and open what you want, and change it back to restore session (in essence clearing it out and starting over again). For some reason, though, this always has been a little bit wonky for me, unfortunately (though I didn't play with it very much to be honest!)

  4. #4
    Join Date
    Jul 2012
    Location
    /tropics/islands/statia
    Beans
    275
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Disable autostart apps

    Quote Originally Posted by cortman View Post
    Can you reverse the process given here?
    No, because the file manager is not listed in the Autostart. I had checked that already.

    There is something there which makes me wonder if it is correct:
    gtk2-default-theme.rc.sh is listed twice: once under Startup, once under pre-KDE startup.

    EDIT: removed the instance under pre-KDE startup, logged out, log back in, it's back again...
    Last edited by Statia; August 8th, 2012 at 11:00 PM.

  5. #5
    Join Date
    Jul 2012
    Location
    /tropics/islands/statia
    Beans
    275
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Disable autostart apps

    Quote Originally Posted by drmrgd View Post
    you could try to change the selection to start new session, log out and back, and open what you want, and change it back to restore session (in essence clearing it out and starting over again). For some reason, though, this always has been a little bit wonky for me, unfortunately (though I didn't play with it very much to be honest!)
    That solved it, thanks!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •