Results 1 to 10 of 14

Thread: unetbootin, failure to boot after creation

Threaded View

  1. #11
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: unetbootin, failure to boot after creation

    Quote Originally Posted by F W Adams View Post
    I went and bought another flash USB today and set it up, it was fine.

    I did as you suggested but rather as expected it didn't work. The transfer was of about 1GB from partition 1 of the ok system ( sdd1 ) to the bad one ( sdc1 ). SYNC took about 15 seconds so definately necessary. As expected it turned it into a 1GB device. I haven't looked in detail but the files seem fine, the disk label was transferred as well, it doesn't show as I changed the label of the ok one afterwards. Bad one: according to fdisk the format is FAT16, as it was before the transfer, but gparted has it as FAT16 before the transfer and F32 afterwrds. When booting there was just a blank screen.


    fdisk, mount & two ls -l -R

    Code:
    felix@emma:~$ 
    felix@emma:~$ sudo fdisk -l
    ...
    Disk /dev/sdc: 3869 MB, 3869544448 bytes
    105 heads, 18 sectors/track, 3998 cylinders, total 7557704 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x0009020b
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdc1            2048     7557119     3777536    6  FAT16
    
    Disk /dev/sdd: 3999 MB, 3999268864 bytes
    255 heads, 63 sectors/track, 486 cylinders, total 7811072 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xc3072e18
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdd1   *          63     2152709     1076323+   b  W95 FAT32
    /dev/sdd2         2152710     7807589     2827440    b  W95 FAT32
    ...
    I emailed the supplier today about whether it was a solvable problem, though there's not a lot of consolation in being well paid doing up a parcel and then posting it.

    -------------------

    I was just about to send this when I decided to check something else. The flags ( BOOT in this case ) hadn't been transferred by dd, is this what you would expect? I was expecting the flag to be transferred. The working version had BOOT set on partition 1, but not the copy. When I manually set the boot flag it fixed the problem. Booted ok and files seem ok.

    I'll mark as solved when I'm more sure it works.

    I'm still surprised that your method worked, well, with a tiny bit of help, and yet the dd'ing the zeros didn't.
    The target pen-drive is smaller than the source one

    Disk /dev/sdc: 3869 MB
    Disk /dev/sdd: 3999 MB

    also heads, sectors/track and cylinders differ.

    When the target is smaller the dd cloning is truncated. This might cause problems. Also it is strange that the heads, sectors/track and cylinders differ. 255 heads, 63 sectors/track are standard values for modern drives. Maybe it would help if you change those values. See
    Code:
    man fdisk
    A successful cloning would certainly copy also the boot flag. I'm glad you observed that difference and could fix it

    Anyway, those four pendrives really behave in a strange way.
    Last edited by sudodus; July 16th, 2012 at 10:19 PM. Reason: also heads, sectors/track and cylinders differ

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •