I *need* to update my driver, even though everything seems to work just fine. I got Diablo 3 for my birthday (yay!) and managed to install it using PlayOnLinux. BUT the game won't run, tells me my graphics driver is out of date.
According to the little plastic sticker on my laptop I've an Intel Core i5-480M processor and the grapics card is just presented as Intel Hd Graphics. I don't know if that helps any. I run 11.10.

I kept the pre-installed windows, just repartitioned it when I installed ubuntu, and on my windows boot I was able to install and run the game after updating the driver. I would prefer to run it in ubuntu, though.