This is a new laptop with a Broadcom BCM43227 Wireless adapter. Things worked fine on 11.10. I upgraded to 12.04 last night and this annoying problem cropped up. I can't see my wireless adapters anymore. Instead:

ashesh@ashesh-ofc:~$ rfkill list
0: acer-wireless: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: acer-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
Trying to make & install the Broadcom drivers from their website fails with the following:

KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: Entering directory `/usr/src/linux-headers-3.2.0-25-generic-pae'
Wireless Extension is the only possible API for this kernel version
Using Wireless Extension API
  CC [M]  /home/ashesh/Downloads/bcm/hybrid-portsrc_x86_32-v5_100_82_112/src/wl/sys/wl_linux.o
/home/ashesh/Downloads/bcm/hybrid-portsrc_x86_32-v5_100_82_112/src/wl/sys/wl_linux.c:388:2: error: unknown field ‘ndo_set_multicast_list’ specified in initializer
/home/ashesh/Downloads/bcm/hybrid-portsrc_x86_32-v5_100_82_112/src/wl/sys/wl_linux.c:388:2: warning: initialization from incompatible pointer type [enabled by default]
/home/ashesh/Downloads/bcm/hybrid-portsrc_x86_32-v5_100_82_112/src/wl/sys/wl_linux.c:388:2: warning: (near initialization for ‘wl_netdev_ops.ndo_validate_addr’) [enabled by default]
make[2]: *** [/home/ashesh/Downloads/bcm/hybrid-portsrc_x86_32-v5_100_82_112/src/wl/sys/wl_linux.o] Error 1
make[1]: *** [_module_/home/ashesh/Downloads/bcm/hybrid-portsrc_x86_32-v5_100_82_112] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.2.0-25-generic-pae'
make: *** [all] Error 2
Then I tried to see what Additional Drivers could do for me. It also failed with an error message asking me to see /var/log/jockey.log (attached)

I'm quite clueless about how to approach this now. Any help will be appreciated.