Hi, thanks in advance to anyone who can help with this:

My wireless card (Intel Pro 2200BG) no longer works now I've installed Lubuntu 12.04. It worked fine under Ubuntu 10.04 and still does under Windows.

I'll try and post some relevant information, having read the forum guide. Thanks again.

robert@robert:~$ rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

robert@robert:~$ sudo lshw -C network
[sudo] password for robert:
description: Wireless interface
product: PRO/Wireless 2200BG [Calexico2] Network Connection
vendor: Intel Corporation
physical id: 9
bus info: pci@0000:00:09.0
logical name: eth1
version: 05
serial: 00:16:6f:5d:44:e3
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ipw2200 driverversion=1.2.2kmprq firmware=ABG: (Dec 12 2007) latency=64 link=no maxlatency=24 mingnt=3 multicast=yes wireless=IEEE 802.11bg
resources: irq:5 memory:98180000-98180fff
description: Ethernet interface
product: NetXtreme BCM5705M Gigabit Ethernet
vendor: Broadcom Corporation
physical id: 13
bus info: pci@0000:00:13.0
logical name: eth0
version: 01
serial: 00:08:02:97:6a:a4
size: 100Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 66MHz
capabilities: pm vpd msi bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.121 duplex=full firmware=5705-v3.14 ip= latency=64 link=yes mingnt=64 multicast=yes port=twisted pair speed=100Mbit/s
resources: irq:10 memory:98000000-9800ffff memory:30000000-3000ffff

robert@robert:~$ lspci -nn | grep 2200
00:09.0 Network controller [0280]: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection [8086:4220] (rev 05)

robert@robert:~$ ls -al /lib/firmware | grep ipw
-rw-r--r-- 1 root root 209190 Apr 2 20:51 ipw2100-1.3.fw
-rw-r--r-- 1 root root 201138 Apr 2 20:51 ipw2100-1.3-i.fw
-rw-r--r-- 1 root root 196458 Apr 2 20:51 ipw2100-1.3-p.fw
-rw-r--r-- 1 root root 191154 Apr 2 20:51 ipw2200-bss.fw
-rw-r--r-- 1 root root 185428 Apr 2 20:51 ipw2200-ibss.fw
-rw-r--r-- 1 root root 187836 Apr 2 20:51 ipw2200-sniffer.fw