I searched the forum and could not find reference to this type of problem. I have a Panp8 originally shipped with 11.04. Everything worked. Upgraded to 11.10 and everything worked. Upgraded to 12.04 and a strange wireless problem occured.

Network manager sees my wireless access point (with WPA encryption) and supposidly connects with three out of four bars of signal strength. But when I open FireFox and try to connect, the attempt times out saying that the server could not be found. Things that I have tried:

1. Reinstalled 12.04 as a clean install
2. Turned the wireless card off then on with Fn F11
3. System connects with a wired connection
4. My Panp8 connects wirelessly with 11.10 Live CD
5. Wireless works perfectly with all of my other wireless devices, (MacBook Pro, iPad, Acer Aspire One.)
6. sudo lspci results in the following: Intel Corporation Centrino Advanced-N 6230 (rev 34)

Since my network works perfectly with my other devises, and on my Panp8 with earlier versions of Ubuntu, I suspect that the problem lies with an obscure setting. Any help would be appreciated. Thanks.