Results 1 to 5 of 5

Thread: Ubuntu 12.04 installation failing grub install

Threaded View

  1. #1
    Join Date
    May 2012

    Question [SOLVED] Ubuntu 12.04 installation failing grub install

    I don't know what to do with it anymore, every single release of Ubuntu (since I've been using it from 10.04) has had installation problems.

    Right now on 12.04 the issues rise to a climax.

    Let me sketch the situation:

    I'm trying to get dualboot (windows 7 64bit sp1 + ubuntu 12.04 64bit) working on an m17x-R1 alienware notebook.

    Here's the hardware:
    • 2x Nvidia GTX20m in SLI
    • an Nvidia 9800m (disabled in bios)
    • 2x 320GB HDD in raid 0
    • an infrared receiver

    * (I listed the video cards because Ubuntu had issues with that before)

    First I backup all my files, then I reinstall windows 7 (deleting all partitions - including the ubuntu ones that I had) because I want a nice clean computer.

    Windows 7 cleans the partitions, installs nice and easy. I already had my ubuntu live-usb made with 12.04 on it.

    First problem
    The Ubuntu couldn't boot to live-usb, it gave a kernel panic. Apparently it had to do with the infrared receiver inside my notebook. Long story short, I found the bug on launchpad (LINK). Disabling the infrared receiver allowed me to boot into the installation.

    Second problem (?)
    I chose to specify the partitions myself. Although the partition manager went a bit crazy on me I think (maybe this is related to having a raid 0 setup?). In the partition manager UI I saw my partitions and some other strange things:

    This is the path to my drive: /dev/mapper/nvidia_edffafeb

    What I expected to see after I partitioned my free space:
    • /dev/mapper/nvidia_edffafeb1 (windows boot loader)
    • /dev/mapper/nvidia_edffafeb2 (windows drive)
    • /dev/mapper/nvidia_edffafeb3 (/boot)
    • /dev/mapper/nvidia_edffafeb5 (/)
    • /dev/mapper/nvidia_edffafeb6 (swap)
    • /dev/mapper/nvidia_edffafeb7 (/home)

    but there were "copies" of the windows partitions there - which I couldn't edit (gave ubi-partman error code 141).

    looked like this: (tree structure)

    /dev/mapper/nvidia_edffafeb1 (windows boot loader)

    /dev/mapper/nvidia_edffafeb2 (windows drive)

    /dev/mapper/nvidia_edffafeb3 (unpartitioned space)

    Anyhow, I left those like they were and selected
    /dev/mapper/nvidia_edffafeb for the grub-install.

    Ubuntu installed fine after this point.

    Third problem
    After Ubuntu installation a problem I had earlier came up again - the grub-install failed on /dev/sda. Although I specified it to be on /dev/mapper/nvidia_edffafeb.

    No matter, I could reselect the location and did so accordingly.

    grub-install failed again; it couldn't install to (hd0) was the message.

    I then chose it to install to /dev/mapper and other paths.
    Each of them failing.

    Exited saying: continue without installing boot loader.

    Fourth problem
    I rebooted to my live-usb again and got boot-repair working. It did it's auto-fix procedure and gave me this log (LINK).

    When I rebooted I got into grub and it gave me 4 options:

    • Ubuntu, with Linux 3.2.0-24-generic
    • Ubuntu, with Linux 3.2.0-24-generic (recovery mode)
    • Memory test (memtest86+)
    • Memory test (memtest86+, serial console 115200)

    *My windows was gone*

    booted into recovery mode - ran grub repair there. and it gave me 4 extra boot options on top of the ones above:

    • Windows 7 (loader) (on ./dev/mapper/nvidia_edffafeb1) - this one boots into windows
    • Windows 7 (loader) (on ./dev/mapper/nvidia_edffafeb2)
    • Ubuntu, with Linux 3.2.0-24-generic (on ./dev/mapper/nvidia_edffafeb6)
    • Ubuntu, with Linux 3.2.0-24-generic (recovery mode) (on ./dev/mapper/nvidia_edffafeb7)

    Fifth problem
    The actual boot...
    When trying to boot the first option (try to visualize both lists above as if they were under eachother) it gives me 2 "inotify watch" errors which disappear too fast for me to read and then turns into a half purple screen with some fragments on it (hangs there)
    -same issue when trying to boot the ubuntu on nvidia_edffafeb6-

    *Of course the infrared receiver had to be blacklisted here as well!*

    edited parameter of first option: added "ite_cir.blacklist=yes" at the end of the parameter list.
    This one actually booted a little bit, but loops endlessly in the "ubuntu ° ° ° ° °" screen where the dots change white to purple and visa versa.

    Any idea on how I can actually make this work?

    Thanks in advance.
    Last edited by desater; May 16th, 2012 at 04:59 PM. Reason: solved

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts