Did someone mange to change the behavior of the gpg-agent?

I tried to enter some of the parameters to the gpg-agent.conf according to the man gpg-agent, but all this seems to have no function at all.

I tried to modify the gpg-agent.conf which is in my home dir under gnupg.

I would like to either disable the passphrase caching completely or set it to some value like 10sec or so.
Neither seems to work.