Results 1 to 5 of 5

Thread: 12.04 switching desktops shortcuts no longer work

  1. #1
    Join Date
    Oct 2007
    Beans
    24

    Unhappy <SOLVED> 12.04 switching desktops shortcuts no longer work

    I just upgraded to 12.04 and am running gnome-shell.

    Code:
    $  echo $DESKTOP_SESSION
    gnome-shell
    I have keyboard shortcuts to switch directly to desktop N (CTRL-F1 goes to desktop 1, CTRL-F2 goes to desktop 2, etc). I can see the shortcuts are still set in the keyboard settings, but they don't work.

    I can use CTRL-ALT-UP and CTRL-ALT-DOWN to cycle through desktops, but that really really sucks when I'm on desktop 5 and want to go to 1 directly.

    Anyway to get the shortcuts to work again?
    Last edited by hemna; May 1st, 2012 at 07:50 PM.

  2. #2
    Join Date
    Feb 2006
    Beans
    10
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: 12.04 switching desktops shortcuts no longer work

    I'm seeing same issue, 12.04 running gnome 3. I had my multimedia keys set for various tasks (switching to specific workspaces, launching a terminal, etc). I run the keyboard shortcut GUI and it shows the buttons assigned properly, but they simply don't work. Tried un-assigning and re-assigning, no difference.

  3. #3
    Join Date
    Jun 2007
    Beans
    17,105

    Re: 12.04 switching desktops shortcuts no longer work

    For gnome-shell you can set such things thru gsettings, graphically thru dconf-editor, see screen
    org.gnome.desktop.wm.keybindings

    I used Ctrl, Control should also work
    ['<Ctrl>F1']

    (dconf-editor is in dconf-tools, to make or edit a key click in the area so it turns 'white'. Then add/edit & set by pressing enter on keyboard while cursor is still in the edit area. Don't click out or no entry/edit will be made

    Edit: to use cli thru gsettings the above
    Code:
    gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-1 "['<Ctrl>F1']"
    Attached Images Attached Images
    Last edited by mc4man; May 1st, 2012 at 07:45 PM.

  4. #4
    Join Date
    Feb 2006
    Beans
    10
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: 12.04 switching desktops shortcuts no longer work

    Hi,

    I found that it can be set through dconf-editor, or I can edit /usr/share/glib-2.0/schemas/ files directly, but the issue I'm having is I have a Microsoft Ergonomic Keyboard (http://www.microsoft.com/hardware/_b...herviews01.jpg), and I want to use those numbers at the top labeled 1-5. The issue is I don't know how to specify to use those keys. When I set it using the graphical tool in system settings -> keyboard, it's labeled as 'Launch5'-'Launch9' (for 1-5). I can also use xev and get keycode values of 192-196, but again I don't know what to put into dconf to tell it to use that key. Any ideas?

    Thanks.

  5. #5
    Join Date
    Feb 2006
    Beans
    10
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: 12.04 switching desktops shortcuts no longer work

    A Ha! Found it by looking at gconf-editor, even though those settings don't take effect, I can set the key in the GUI from System Settings -> Keyboard, then look at gconf-editor to see what value it gives the key, then set that value using 'gsettings set' or dconf-editor! What a PITA tbh but it works.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •