Make sure wifi and touchpad are enabled. The default may be to have them turned off.