Good Morning

I am try to get 1 pic out of my phone and I cannot get it to connect
phone details
Samsung Galaxy S GT-I9000
Firmware 2.2
Baseband Version I9000HVJP3
Kernel #6
build number FRoyo.hvjp4

I am using ubuntu 10.10 classic desktop fully updated.

I have even tried the Kies software but have a driver issue with Marvell 91xx driver not updated on window & 64bit. Therefore back to trusty ubuntu

So I go
setting ==> wireless & networks ==> USB settings ==> Mass storage
connect cable (phon charges ok out of interet)

Get USB connected and green andriod. Button at bottom 'Connect USB Storage. BLue bar at top USB mass storage

nothing at this point

Drag down notification (grey) bar at top

Tap line with the following on it
'USB connected
Select to copy files to/from your computer'

Back to green android as per above

Tap button and button now says 'turn off' and andriod changes to orange in colour

Still nothing.

Tried using the debug mode, dont allow screen to turn off and debugg mode, and a few other random stabs in the dark but still nothing

Anyone got any ideas on how to get this darn pic of my kids covered in mud of my phone????