Results 1 to 5 of 5

Thread: Cannot boot windows

  1. #1
    Join Date
    Apr 2012
    Beans
    12

    Exclamation Cannot boot windows

    I boot a ubuntu 11.10 32 bit release off my HP SimpleSave External HDD.
    I did this in order to be able to run my ubuntu on any pc.
    However, I realized that after booting off the external hdd, Windows (originally on the pc), would not boot! Instead, the BIOS shows a message saying:
    could not find device *really long set of letters and numbers*
    grub_rescue>
    Please help, I am getting this on both pcs I tried it on!
    Thanks

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Cannot boot windows

    Welcome to the forums.

    You probably used one of the auto install choices and with multiple drives you have to use manual install or Something else to get a choice on which drive's MBR to install the grub2 boot loader.

    You need to reinstall a Windows boot loader to the internal drive's MBR and install the grub2 boot loader to the MBR of the external. Grub2 also remembers where to reinstall on a major update to grub, so you need to fix that or sometime later it may happen again. Then in BIOS set to boot from external drive when you want Ubuntu.

    Boot Problems:Computer does not boot without external drive
    http://sourceforge.net/apps/mediawik...external_drive

    If you want to just install boot loaders, reinstall grub2's boot loader first or else you will have to use liveCD:
    How to restore the Ubuntu/XP/Vista/7 bootloader (Updated for Ubuntu 9.10 - grub2) - talsemgeest
    http://ubuntuforums.org/showthread.php?t=1014708
    Reinstall grub2 - Short version & full chroot version
    https://help.ubuntu.com/community/Gr...alling%20GRUB2

    #reinstall from working (not liveCD) system - first find Ubuntu drive (example is drive sdb but use your drive not partitions):
    sudo fdisk -l
    #if it's "/dev/sdb" then just run:
    sudo grub-install /dev/sdb
    #If that returns any errors run:
    sudo grub-install --recheck /dev/sdb
    sudo update-grub

    #To see what drive grub2 uses see this line - grub-pc/install_devices:
    sudo debconf-show grub-pc
    #to get grub2 to remember where to reinstall on updates:
    sudo dpkg-reconfigure grub-pc
    #Enter thru first pages,spacebar to choose/unchoose drive, enter to accept, do not choose partitions
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Apr 2012
    Beans
    12

    Smile Re: Cannot boot windows

    Thank You, I will try this.

  4. #4
    Join Date
    Apr 2012
    Beans
    12

    Re: Cannot boot windows

    Thank you so much!
    It works perfectly.

  5. #5
    Join Date
    Jul 2005
    Location
    USA (Springfield,Vermont)
    Beans
    755
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cannot boot windows

    Quote Originally Posted by furmada View Post
    Instead, the BIOS shows a message saying:
    Not a BIOS error. Your GRUB is broken.
    Last edited by RJARRRPCGP; April 7th, 2012 at 08:57 PM.
    Acer Aspire M5630: 1 GB Kingston PC6400 DDR2 SDRAM dual channel (2x512 MB), Core 2 Duo E2180 (2.0 Ghz), Intel i915

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •