Results 1 to 3 of 3

Thread: OpenLDAP possibly starting too late?

  1. #1
    Join Date
    Aug 2007

    OpenLDAP possibly starting too late?

    Hi, I recently followed a tutorial on how to get OpenLDAP running with Samba on Lucid. It worked pretty well.

    Here's my very frustrating problem with it. For the first 5 - 10 minutes after rebooting, password handling (possibly PAM?) is hosed, including for users in LDAP authenticating via Samba.

    In fact, I think the only reason I can SSH into the machine during that window is because I happen to have certificate authentication enabled and my client uses that.

    When I try to do a sudo command after logging in, though, and have to enter the password, it hangs. I've searched logs and haven't come up with much.

    I *think* it's related to this bug, but I'm not sure.

    And here's what's killing me ... it's not easy for me to figure out how to ensure that slapd starts before smbd and rsyslog (I read somewhere else that it needs to start before that for some reason) b/c most of the jobs are upstart jobs, but slapd is not.

    By default it runs at S19 in rc2.d, and I've tried manually lowering that as far as S05 or S07, but I'm still having trouble.

    Has anyone fixed this satisfactorily in 10.04 or have an idea that might help me?


  2. #2
    Join Date
    Aug 2007

    Re: OpenLDAP possibly starting too late?

    Here's my /etc/nsswitch.conf, in case that's of interest, based on changes from the aforementioned HOWTO:

    # /etc/nsswitch.conf
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.

    # pre_auth-client-config # passwd: compat
    passwd: files ldap
    # pre_auth-client-config # group: compat
    group: files ldap
    # pre_auth-client-config # shadow: compat
    shadow: files ldap

    hosts: files dns
    networks: files

    protocols: db files
    services: db files
    ethers: db files
    rpc: db files

    # pre_auth-client-config # netgroup: nis
    netgroup: nis

  3. #3
    Join Date
    Aug 2007

    Re: OpenLDAP possibly starting too late?

    Actually, as I get back to this problem much later, I've concluded that what I may have been experiencing was the exact same as this poster, and his solution may've solved my problem to (just doing the net rpc join command):

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts