Hey guys.

First post, so please excuse me if this is wildly "off-kilter" in some way. I've done a lot of searching, but haven't been able to find a functioning fix yet.
So, this is my first experience with a Linux-based system. I don't go into things in total stupidity, I've tried to get a good idea of where to go for a few days now. Installed the latest version of Ubuntu with no problems.

I installed it on my iMac from around 2008-2009, which already had Windows 7 Ultimate running on a 140gb bootcamp partition. From a few sites I read, it was still possible to install Ubuntu without any major problems. What I wound up doing was using Disk Utility to further divide the primary partition (OSX).

Got onto the Windows OS, installed Ubuntu via dvd. Ran into no problems, Ubuntu works fine. I run into my issue when attempting to actually run the Windows OS.
When I start up via rEFIt, I select Windows, and GNU Grub starts up. Selecting Windows then leads to this:

Windows Boot Manager

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:
1. Insert your Windows installation disc and restart your computer.
2. Choose your language settings, and then click "Next."
3. Click "Repair your computer."

If you do not have this disc, contact your system administrator or computer manufacturer for assistance.

File: \Boot\BCD

Status: 0xc0000225

Info: An error occurred while attempting to read the boot configuration data.

(Enter to continue, ESC to exit)
This is totally unresponsive, only way to proceed is hard-restarting.
Now, I've tried booting from the install disc. The thing is, it still goes through GNU Grub, and when I attempt go fix anything via the recovery applications I'm told that a partition isn't selected. Even though I had to select, at rEFIt and GNU Grub.

When I'm at the recovery section and open up the command prompt, I've tried listing all available partitions, but it only shows two. One of nearly 1TB (original HD, shown without partitions), and one that's empty.

SO. I'm sorry for the extremely long-winded explanation, but if you need any more info please feel free to ask. I'm still extremely inexperienced with Ubuntu and Linux in general, so I apologize for any slowness on my part.
Any help would be greatly appreciated!