Results 1 to 10 of 344

Thread: Testers needed for PowerPC 12.04

Threaded View

  1. #11
    Join Date
    Feb 2012

    Re: Testers needed for PowerPC 12.04

    I've got this PowerBook G4 2002 TiBook, and finally got Ubuntu running on it. (I'm writing this on it right now.) Then I found this thread, and thought I'd post some info.

    It's running 12.04 with all the updates as of right now.

    The Live CD couldn't make the HFS drive a bootstrap/yaboot compatible drive or something like that, the alternative CD could though, and did. I used dd on a PowerMac G4 running Leopard to write the ISOs to a 1gb USB drive, and booted the laptop off of that.

    All versions 10 would not show anything on screen upon booting from the USB, save for a few lines.

    The mini CD for 11 couldn't make the internal drive boot without help, but That was almost a week ago that I last tried that.

    The reason I tried installing Ubuntu on this thing is because the Mac OS 10.5 system it had on it had terrible graphical glitches, to the point that you couldn't see anything. I had fixed it once by installing the system anew, but the disc drive doesn't work anymore. I thought it must be the logic board had gone out, but I wasn't sure. So when I found out that Ubuntu 12 fixed everything, I knew it must've been the system.

    The sound is not working right now, after I installed updates, but was working fine right after system install. I had/have to press fn with the volume buttons for them to work. However, the microphone level meter shows input when I'm yelling at the computer for not playing music. (lol) So the speakers and headphone output aren't working, but the microphone and sound input is.
    EDIT: Nevermind that. (look down for info)

    The simulated right click isn't working now either after updates. Ctrl click doesn't even work on an i386 pc. So, being deprived of my spell checking abilities, there may be some typos in this post.
    EDIT: Nevermind this too.

    The display works great when the system is giving it a signal, without any glitches whatsoever. But when the screen isn't getting any signal, the backlight and power stay on, but the picture gets buggy like a cheap LCD screen when it's turned off. (The picture slowly fades away, but a lot more slowly than it usually does.)

    The screen also gives this response a few times during booting, but I find that almost natural. BUT when I change to a resolution other than the native (1280 by 854) it's the same thing. No signal. Luckily the timeout returned the screen to the previous resolution, restoring the picture without any further problems.

    I haven't tried rotation yet because I want to get this posted before risking it.
    EDIT: I tried rotation, and strangely it gives me graphical glitches amazingly similar to the ones I had on Mac OS X before I wiped it and installed Ubuntu 12.04. It does this at all three non-normal settings. I can see enough to click the restore button, which brings back the crystal clear picture I've come to know and love from Ubuntu on this computer.

    The brightness buttons don't work, but I believe someone else mentioned that.

    The battery works when I unplug the laptop, but doesn't seem to have any settings or indicators anywhere. However it wasn't in the computer when I installed the system, nor for the first boot, so that may be my fault.

    The system runs a lot hotter than Mac OS X did, but both fans work, which is more than OS X did most of the time. I'm not worried about this though. Taking the keyboard off and touching the heat sinks and metal covers is more painful than it was with OS X, but that's the only way I'd know it was running hotter. OS X probably should have been running like this. There are temp warnings in there after all.

    The keyboard's num lock doesn't work, but this may not be a bug.

    Pressing f11 doesn't work to make anything fullscreen, it seems to cut and move text around. This is probably a result of my own ignorance though.

    My "u" key keeps falling off. (The worst bug. FIX THIS NOW!) lol

    Other than that everything seems to be working fine. As much as a community supported pre-released operating system should be anyway. Slight software incompatibilities, but I don't consider those bugs yet.

    PS I accidentally just hit f12 and realized that it made a right click! I knew f12 was supposed to do that, but never had any luck with other computers. but I'm not going to go back and spell check everything because I'm feeling lazy. That and I have other more vital stuff to do. So maybe that means I'm feeling more diligent. lol

    EDIT: I forgot to mention that this PowerBook doesn't have an AirPort card in it, so I can't say anything about that. But it does work with a Belkin USB Wireless antenna (F5D7050) that all Ubuntu versions have worked with since 7.10 (when I started using it.)

    Also, a few more updates and a restart, sound seems to be working again. A few pops and such when starting audio, but it did that before as well. I have a feeling this one may have been my fault.

    Simulated right clicking is working again as well.

    I'm happy.
    Last edited by AnsonX10; February 8th, 2012 at 10:53 PM. Reason: Rotation Info'mation! And edits.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts