Results 1 to 7 of 7

Thread: The amd64+mac iso and Trouble booting ubuntu/backtrack/actually any distro

Threaded View

  1. #1
    Join Date
    Feb 2006
    Beans
    65

    The amd64+mac iso and Trouble booting ubuntu/backtrack/actually any distro

    Ubuntuists,

    I have been trying to boot ubuntu on my macbook early 2011 for a while now. I remember it used to work as I booted ubuntu 10.11 once.

    The problem is that when I boot the 11.10 CD I get dropped to a (initramfs) prompt as the environment doesn't seem to be able to find the live filesystem.

    When fiddling around a bit in this environment I find out that I have no /dev/sdb device node. Seems that is the reason why the live filesystem cant be found, as that is where the DVD drive should be.

    I then found out about the amd64+mac iso (http://cdimage.ubuntu.com/releases/11.10/release/) and burned that to a DVD. The issue still persists however. Is this a known issue? Any fixes?

    Furthermore, not entirely related however:

    I am trying this because I can't seem to boot a backtrack iso (which has the same problem). As a workaround I tried to use a usb drive loaded with backtrack using unetbootin. As the EFI bootloader does not allow booting from usb appearently I had to install rEFIt on my macbook's EFI partition. it seems rEFIT is quite outdated however.

    I tried booting a ubuntu 11.10 usb stick and a backtrack 5r1 usb stick and both give me a 'Operating System Not Found' error. The sticks are however working fine on a regular (BIOS) PC. When I have a ubuntu cd inserted and I choose rEFIt's 'Boot Linux from USB' the CD gets booted instead.

    Any suggestions? Thanks in advance, and I don't seem to be the only one having this problem.
    Last edited by peter rus; January 26th, 2012 at 03:32 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •