Quote Originally Posted by pros View Post
googlearth 6 font rendering issue

Solved in LUCID 64bit

Move to a different location or simply delete following files

/opt/google/earth/free/libQtWebKit.so.4
/opt/google/earth/free/libQtNetwork.so.4
/opt/google/earth/free/libQtGui.so.4
/opt/google/earth/free/libQtCore.so.4

Now you need some 32 bit packages that you can find in http://packages.ubuntu.com/
install libfreeimage3 32 bit- libfreeimage3_3.10.0-2_i386.deb (uncompress i386 deb and copy in /usr/lib32 following files: libfreeimage.so.3, libfreeimage-3.10.0.so, libfreeimageplus.so.3, libfreeimageplus-3.10.0.so)

install libphonon4_4.6.2-0ubuntu5.2_i386.deb (uncompress i386 deb and copy in /usr/lib32 following files: libphonon.so.4, libphonon.so.4.4, libphonon.so.4.4.0 and finally put in /usr/lib/qt4/plugins/designer file libphononwidgets.so)

change last line of /opt/google/earth/free/googleearth to

export LD_PRELOAD=/usr/lib32/libfreeimage.so.3
LD_LIBRARY_PATH=/usr/lib32:.:$LD_LIBRARY_PATH ./googleearth-bin "$@"
Worked great for me with Google Earth 6.1.0.4857 Beta and Linux Mint 11.10 64-Bit - so many thanks! Obviously the exact lib names varied slightly with being on Oneiric, but the basic procedure was correct - I just pasted whatever I'd got from the relevant .deb files into the relevant folders. Also, I didn't have a libphononwidgets.so, but it didn't seem to matter...

Thanks again!