Results 1 to 3 of 3

Thread: Can't access web development server using LAN IP

  1. #1
    Join Date
    Feb 2009
    Ubuntu 9.10 Karmic Koala

    Can't access web development server using LAN IP

    I am trying out Google App Engine on Eclipse 3.5. I am able to access the web server and application through localhost as well on the same machine. But I can't access it through the 192.168.2.x either on the same machine or another machine in the local network. I also tried running an app from the command line (without Eclipse) and I got the same result.

    I have used GlassFish on Netbeans before, and I recall I didn't have much trouble accessing it then. Any suggestions? Thanks.
    Happy GNU/Linux user. Not so noob anymore!
    There are only 10 types of people in the world — those who understand binary, and those who don't.

  2. #2
    Join Date
    Sep 2009
    Ubuntu 10.04 Lucid Lynx

    Re: Can't access web development server using LAN IP

    firewall? look in system->admin-> for a firwall option otherwise google iptables, also i'd reccomend installing webmin to manage all your network/host settings (makes life easyer).

    hope this helps

  3. #3
    Join Date
    Aug 2006

    Re: Can't access web development server using LAN IP

    I imagine after 2 years you've probably worked around this problem, but for anyone else who found this as the first relevant search result when attempting to solve this problem, I found this:

    Which suggests using the proxy pen:

    sudo apt-get install pen
    pen 8079 localhost:8888

    This will cause any traffic coming in through 192.168.1.x:8079 to be forwarded to the local GAE server on 8888.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts