Results 1 to 10 of 14

Thread: USB drive appears unformatted.

Threaded View

  1. #1
    Join Date
    Apr 2010
    Beans
    51

    USB drive appears unformatted.

    Hi-

    I have got this usb drive that has exhibited the following behavior a few times:

    Format drive (different fs types, sometimes 1 sometimes more partitions)
    use drive 3-5 times with no issues
    Drive appears unformatted and is useless.
    Can't run recovery software.

    Plugging in the device results in nothing but a stub:
    There's an entry in the dev folder, /dev/sdb
    and lsusb shows the device.

    That's it.
    Gparted doesn't detect the device at all.
    Disk Utility shows the device as an unformatted "memory bar"
    dd, ddrescue and the like say "no medium found"

    Now, I am stupid for having used the device more than twice. Twice of the same sort of error and no solution should have made me move on to a different device.

    Currently there are (were) couple of large files on the drive. I'd like to be able to try and recover them.

    But with no partitions showing up and only disk utility with it's basic "reformat it" tool available do I have any possibility of bringing those files back?

    Thanks,
    wigout

    INFO:
    I'm running 11.10 64bit, usb drive is 8gb vfat.

    dd if=/dev/sdb of=sdb.test
    dd: opening `/dev/sdb': No medium found


    ddrescue /dev/sdb test
    ddrescue: Can't open input file: No medium found


    sudo mount /dev/sdb mountpoint
    mount: no medium found on /dev/sdb


    lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 003: ID 0408:2fb1 Quanta Computer, Inc.
    Bus 002 Device 010: ID 090c:1000 Feiya Technology Corp. Flash Drive
    Bus 002 Device 004: ID 8086:0189 Intel Corp.


    dmesg
    [80217.424224] usb 2-1.2: new high speed USB device number 11 using ehci_hcd
    [80218.144915] scsi16 : usb-storage 2-1.2:1.0
    [80220.035727] scsi 16:0:0:0: Direct-Access USB MEMORY BAR 1000 PQ: 0 ANSI: 0 CCS
    [80220.035976] scsi: killing requests for dead queue
    [80220.036297] scsi: killing requests for dead queue
    [80220.043423] scsi: killing requests for dead queue
    [80220.049077] scsi: killing requests for dead queue
    [80220.055408] scsi: killing requests for dead queue
    [80220.055727] scsi: killing requests for dead queue
    [80220.059436] scsi: killing requests for dead queue
    [80220.059760] scsi: killing requests for dead queue
    [80220.063759] sd 16:0:0:0: Attached scsi generic sg2 type 0
    [80220.063769] sd 16:0:0:0: Embedded Enclosure Device
    [80220.065382] sd 16:0:0:0: Failed to get diagnostic page 0x8000002
    [80220.065395] sd 16:0:0:0: Failed to bind enclosure -19
    [80220.071077] sd 16:0:0:0: [sdb] Attached SCSI removable disk

    sudo gparted /dev/sdb
    ======================
    libparted : 2.3
    ======================
    Error opening /dev/sdb: No medium found


    hdparm /dev/sdb

    /dev/sdb:
    HDIO_DRIVE_CMD(identify) failed: Bad address
    readonly = 0 (off)
    readahead = 256 (on)
    geometry = 1024/0/62, sectors = 0, start = 0
    Last edited by wigout; January 8th, 2012 at 05:36 PM. Reason: added command outputs

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •